RPKI RRDP/rsync repositories unreachable

Postmortem

At 13:00 EST (UTC-5) today (13 NOV 2025), ARIN began restricting access to the sites that serve the ARIN Resource Public Key Infrastructure (RPKI) Hosted and RPS (hybrid) repositories. At 13:30, all access to the RPKI repositories was administratively blocked, simulating a full repository outage. At 14:30, access to the repositories was restored. Full redundancy of RPKI services was confirmed at 14:35, and the RPKI system returned to pre-test levels at 14:50.

This decision to conduct the test in ARIN’s production environment was carefully considered. Testing outside of production would not have provided an accurate representation of performance and preparedness for repository failure conditions. Therefore, ARIN chose to simulate this scenario in a live environment to best evaluate real-world impacts and response.

We appreciate the patience and cooperation of the RPKI community throughout this exercise and conduct this testing as part of our commitment to high-quality RPKI services.

Regards,
Brad Gorman
Director, Customer Technical Services
American Registry for Internet Numbers

Posted Nov 13, 2025 - 15:02 EST

Resolved

Full reachability to the ARIN RPKI repositories (RRDP/rsync) has been restored.
Posted Nov 13, 2025 - 14:35 EST

Update

Loss of reachability to the ARIN RPKI repositories (RRDP/rsync) has been confirmed.
Posted Nov 13, 2025 - 13:39 EST

Monitoring

Degraded reachability to the ARIN RPKI repositories (RRDP/rsync) has been detected.
Posted Nov 13, 2025 - 13:11 EST
This incident affected: Registry Services (RPKI RRDP Repository, RPKI Rsync Repository).